Increased error rates on FME AI Assist for regex, SQL and Python parameters

Incident Report for Safe Software

Resolved

The third-party vendor has resolved the timeout issues impacting AI Assist. The service is now fully functional.
Posted Jul 25, 2025 - 09:16 PDT

Monitoring

The timeout rate has decreased, indicating that a third-party vendor issue is the likely cause. We continue to monitor the situation.
Posted Jul 24, 2025 - 15:51 PDT

Investigating

We are seeing an increased timeout frequency when using the AI Assist in FME Form. This only applies to parameter-level AI Assist features – namely, SQL, Regex, and Python assistance.

Users of this feature are more likely to experience failed requests for AI parameter assistance. Retrying may succeed.

We suspect a third-party vendor issue, but we are currently investigating to rule out other possibilities.
Posted Jul 24, 2025 - 15:25 PDT
This incident affected: FME AI Service.