FME Cloud: Incompatible linux kernels issue
Incident Report for Safe Software
Resolved
[2017-07-04] Update: The newest Ubuntu security updates for 14.04 and 16.04 kernels resolved the incompatibility with FME. All FME Cloud instance running on the newest security updates won't be affected by this issue. All instances with pending security updates should be either restarted (unattended-upgrades) or user initiated security updates should be applied to make sure the instance is up to date.

[2017-06-22] This issue has been resolved and all instances launched as of Thursday, June 22nd, 2017 will not be affected anymore.

Instances launched before Thursday, June 22nd, 2017 will still be affected if unattended security updates are enabled and they were restarted after Monday, June 19th, 2017 or user initiated Security updates have been applied after Monday, June 19th, 2017. We are hopeful that a fixed version of the Kernel will be released soon, in which case we will publish another update.

Please contact support@fmecloud.com if your instance is affected and you experience unexpected workspace failures. Please attach a log file of the affected workspace and grant us permission to access your instance via SSH to apply a permanent fix.

We apologize for the inconvenience this may have caused and appreciate your patience.
Posted about 2 months ago. Jul 04, 2017 - 17:55 PDT
Investigating
On June 19th, 2017, Ubuntu released a security update for both the 14.04 and 16.04 kernels that are incompatible with FME (http://fme.ly/1604usn, http://fme.ly/1404usn).

Symptom:
FME workspaces will crash if the FME Engine interacts with Java. This includes all translations that use Database or Web Connections, AWS transformers, JDBC formats.

Who is affected:
All instances with unattended security updates enabled that were restarted after Monday, June 19th, 2017.

All instances with user initiated Security updates applied after Monday, June 19th, 2017.

Temporary Resolution:
Please contact support@fmecloud.com if your instance is affected and you experience unexpected workspace failures. Please attach a log file of the affected workspace and grant us permission to access your instance via SSH to apply a temporary fix.

If your instance has outstanding security updates pending please disregard and do not restart the instance until further notice.

Permanent Resolution:
We are still investigating and will keep http://status.safe.com/ updated while we are working on a permanent resolution.

We apologize for the inconvenience this may cause.
Posted 2 months ago. Jun 21, 2017 - 11:04 PDT